Jump to content

NasCRD

Inactive
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

0 Neutral

About NasCRD

  • Rank
    J's Spec

Personal Information

  • Name
    Jay
  • Gender
    Male
  • Location
    Perth, WA
  • Cars
    2002 Nissan Silvia S15 Spec R
  1. My s15 currently has a leak in the steering rack.. I was told it would need refurbishing or a replacement. I've looked at getting it refurbished and it seems it would be better to buy a new or secondhand after looking at prices.However I can't find one anywhere! Can anyone suggest me any shops,sites etc. Thankyou
  2. i thought there would be a knob on the top mounts, however there insnt. theres just a nut. would upload pics if i could understand how to
  3. So I got my car not long ago which came with a set of GP Sports GMaster coilivers installed. However they're super bumpy on the street and wanted to try adjust the dampening to make it softer. I havnt been able to find any instructions anywhere online for this. I thought there was meant to be a pin or knob which allows you to turn however my one just has a bolt. Help is much needed. Thanks
  4. So I got my car not long ago which came with a set of GP Sports GMaster coilivers installed. However they're super bumpy on the street and wanted to try adjust the dampening to make it softer. I havnt been able to find any instructions anywhere online for this. I thought there was meant to be a pin or knob which allows you to turn however my one just has a bolt. Help is much needed. Thanks
  5. Yea I removed and cleaned #1 spark plug, still no good Will be checking injectors later on and doing a compression test tmr. The coil packs and wiring is all good as I've swapped and tested
  6. Already tried swapping the coil packs from another cylinder, still no good from cylinder 1..
  7. Checked , spark plugs are right, coil packs and looms are all in tact. Whenever I disconnect coil loom from cylinder 1 nothing happens. However when I disconnect from 2,3,4 the engine drops revs so that's all okay. I'm hoping nothing wrong with cylinder 1, piston.. Any ideas?
  8. Yes I have a boost gauge in the car, I've driven it a bit more however it really doesn't have power. Won't make it up a hill in 2nd. It backfires time to time and is quite spluttering when idling and driving if you understand what I mean.
  9. I was driving my car yesterday and I was in boost, suddenly the boost cut off and my car began spluttering. As I pulled up to a set of lights my car would have trouble idling and kept switching off. As it turned out my intercooler pipe had come loose. Tightening it up fixed the engine idling issue however my car does not have the power it did before. Seems as if it may be running on 3 cylinders only.. Could that cause the power loss issue? How can the car be fixed if anyone has any idea? Car was running on 0.6 bar with a front mount, cold air intake and IHI Japan vj14 turbo.. Just also want to
  10. Car does nothing, then spools around 4500, then at 5k pulls at 0.6bar
  11. VF14 sounds right, as I know it was a similar to stock turbo t25, Will hopefully be taking out car tmr night, so I can check boost its running.. Car also has stock ecu.
  12. The series number on the turbo was hard to read, may have said VJ14 But I havnt really found much about it online. I have to check how much boost its running because I havnt yet. No exhuast leaks from the car. Other than that it's just running a stainless exhuast,front mount and cold air intake.
  13. So I recently bought an s15, the stock turbo has been replaced for a IHI Japan turbo. However my car isn't pulling full boost until 5k and I want to know if that's normal? Does it need a tune due to the different turbo or could it be so other issue?
×
×
  • Create New...