Jump to content

S15 ADM -> JDM + Nistune dramas. no spark or prime


Recommended Posts

Hey all,

 

Have scoured forums up and down for answers on this one, and some advice/help would be great.

 

I attempted an install of a nistune type 4 on my ADM ecu (s15). Struggled with the ground pins as usual, but managed to get them done in the end (although a bit messy) and car ran fine.

Two days later, tried starting, and classic limp mode symptoms, eng light on, ran rich af and chuggy firing with no rev over 2k. Pulled board apart and assumed board tracks were f*&*cked, bought a JDM ecu from andy at hyperdrive and got him to install the nistune, great job.

 

Did the pin swaps: fuel pump relay 106 to 104, and cas swapped 30 + 31.

 

Tried starting, firstly, fuel pump no prime. checked relay, using test light could get pump priming with the test light (could be issue with short? or ground?)

 

Secondly, pulled the spark plugs out, assuming fouled plugs from limp mode. plugs were black af, got replacements, neither old or new plugs would spark - tried a plug + coil pulled out near a ground point and tried ignition. still no spark.

 

my thinking at first was NATS? but thought no, JDM ecu's have no NATS. Immobiliser? would it stop the fuel pump priming AND spark?

 

Another thought I had was that ADM ECU pinouts dont have cas pinouts on 22 and 40 (which the JDM pinout diagrams seem to have) but the other 2 terminals on the actual cas plug seem not to be connected to the ECU harness at all.

 

Any advice would be greatly appreciated.

 

Other info that might be relevant: car has AFC NEO + AVCR wired in. previous owner did wiring, but worked fine before i decided to be a hero. standard fuel pump, have new spark plugs, splitfire coils.

Link to post
Share on other sites

The 4 wires on the cas are power, ground,1 deg and 180deg trigger signal. Inside the loom near the connector both trigger wires have an extra wire spliced in, so you have 4 trigger wires in total but only 2 from the actual cas plug.

 

Hard to tell you what to check over the internet without writing a novel but the nistune software has alot of helpful things to diagnose if you can get it. Id start with making sure the correct base map is loaded, if you load a an ADM one with NATS then that is probably bad. Make sure its not an S14 ecu, the pinout may be slightly different again (it is on the ADM ones).

 

Fuel pump not priming is most likely the ecu pin not being triggered. You could get it priming with the test light because you are just bridging 2 pins on the relay to power the pump . That only confirms the power circuit for the pump and not the actual ground trigger from the ecu.

 

Anyway you need to confirm your ecu and base map are correct before going further.

Link to post
Share on other sites

Cheers for the reply mate. The nistune which originally had adm base map was taken off the adm board, reflashed to jdm basemap and then installed on jdm board, so that's fine, there shouldnt be bats, this is confirmed by nats light next to windscreen staying on. There was a blown eng cont fuse in the bay but that was replaced.

 

The two other triggers that are spliced into cas wires, are they fine staying there? All the jdm pinouts I've seen including the powerfc pinouts (I'm assuming the pfc pinouts are suited for jdms) have those spliced pins as having their own pinout. Is it possible that cas isn't receiving 180 signal and then not priming the fuel pump? That doesn't explain the lack of spark though right? Has this whole exercise tripped my immobiliser for some reason?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...